const regex = /(<(\w+)(?:\/|.*?)>)((\w+\s?)+)(<(?:\/|)\2+>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<(\\w+)(?:\\\/|.*?)>)((\\w+\\s?)+)(<(?:\\\/|)\\2+>)', 'gm')
const str = `'<a class="class">' . \$variable . '</a>'
"<a class="class">" . \$variable . "</a>"
<a class="class">{{ \$variable }}</a>
<a class="class">{{ __("words") }}</a>
<a class="class">some words</a>
<a/>some words<a>
<a/>some words</a>
<a/></a>
<a>Some words</a>
<a><a>Some words</a></a>`;
const subst = `$1{{ __("$3") }}$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);