import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<(\\w+)(?:\\/|.*?)>)((\\w+\\s?)+)(<(?:\\/|)\\2+>)";
final String string = "'<a class=\"class\">' . $variable . '</a>'\n"
+ "\"<a class=\"class\">\" . $variable . \"</a>\"\n"
+ "<a class=\"class\">{{ $variable }}</a>\n"
+ "<a class=\"class\">{{ __(\"words\") }}</a>\n\n"
+ "<a class=\"class\">some words</a>\n"
+ "<a/>some words<a>\n"
+ "<a/>some words</a>\n"
+ "<a/></a>\n"
+ "<a>Some words</a>\n"
+ "<a><a>Some words</a></a>";
final String subst = "$1{{ __(\"$3\") }}$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}