# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<(\w+)(?:\/|.*?)>)((\w+\s?)+)(<(?:\/|)\2+>)"
test_str = ("'<a class=\"class\">' . $variable . '</a>'\n"
	"\"<a class=\"class\">\" . $variable . \"</a>\"\n"
	"<a class=\"class\">{{ $variable }}</a>\n"
	"<a class=\"class\">{{ __(\"words\") }}</a>\n\n"
	"<a class=\"class\">some words</a>\n"
	"<a/>some words<a>\n"
	"<a/>some words</a>\n"
	"<a/></a>\n"
	"<a>Some words</a>\n"
	"<a><a>Some words</a></a>")
subst = "$1{{ __(\"$3\") }}$5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
    print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.