using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\((?:[^()]++|(?1))*\))(*SKIP)(*F)|,";
string input = @" a.""Id"",
a.""Description"",
UJsonObject(
fepv.""Id"",
fepv.""SystemName"",
string_agg(translations.""Translations"", ',') as ""Translations""
) as ""Translations"",
b.""DataSource"",
a.""Name"",
a.""Value""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}