package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\((?:[^()]++|(?1))*\))(*SKIP)(*F)|,`)
var str = ` a."Id",
a."Description",
UJsonObject(
fepv."Id",
fepv."SystemName",
string_agg(translations."Translations", ',') as "Translations"
) as "Translations",
b."DataSource",
a."Name",
a."Value"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}