// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\((?:[^()]++|(?1))*\))(*SKIP)(*F)|,").unwrap();
let string = " a.\"Id\",
a.\"Description\",
UJsonObject(
fepv.\"Id\",
fepv.\"SystemName\",
string_agg(translations.\"Translations\", ',') as \"Translations\"
) as \"Translations\",
b.\"DataSource\",
a.\"Name\",
a.\"Value\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}