$re = '/(\((?:[^()]++|(?1))*\))(*SKIP)(*F)|,/m';
$str = ' a."Id",
a."Description",
UJsonObject(
fepv."Id",
fepv."SystemName",
string_agg(translations."Translations", \',\') as "Translations"
) as "Translations",
b."DataSource",
a."Name",
a."Value"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);