import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\((?:[^()]++|(?1))*\\))(*SKIP)(*F)|,";
final String string = " a.\"Id\",\n"
+ " a.\"Description\",\n"
+ " UJsonObject(\n"
+ " fepv.\"Id\",\n"
+ " fepv.\"SystemName\",\n"
+ " string_agg(translations.\"Translations\", ',') as \"Translations\"\n"
+ " ) as \"Translations\",\n"
+ " b.\"DataSource\",\n"
+ " a.\"Name\",\n"
+ " a.\"Value\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}