const regex = new RegExp('\\d*[^\\W\\d_][^\\W_]*', 'gm')
const str = `win32 backdoor guid:64664646 DNS-lookup h0lla 1234 12.356 jhdsjdhs_jdshjdshds`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);