$re = '/\d*[^\W\d_][^\W_]*/m';
$str = 'win32 backdoor guid:64664646 DNS-lookup h0lla 1234 12.356 jhdsjdhs_jdshjdshds';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;