re = /\d*[^\W\d_][^\W_]*/m
str = 'win32 backdoor guid:64664646 DNS-lookup h0lla 1234 12.356 jhdsjdhs_jdshjdshds'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result