import re
regex = re.compile(r"\d*[^\W\d_][^\W_]*", flags=re.MULTILINE)
test_str = "win32 backdoor guid:64664646 DNS-lookup h0lla 1234 12.356 jhdsjdhs_jdshjdshds"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)