use strict;
my $str = 'win32 backdoor guid:64664646 DNS-lookup h0lla 1234 12.356 jhdsjdhs_jdshjdshds';
my $regex = qr/\d*[^\W\d_][^\W_]*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";