#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<h6 class="panel-title">\s*<i class="icon-file-music2"><\/i>(.*?)<i class=" icon-info3 text-success" data-popup="tooltip" data-html="true" title="(.*?)" data-placement="bottom"><\/i>\s*<\/h6>"
Local $sString = "<div class="panel-heading">" & @CRLF & _
" <h6 class="panel-title"><i class="icon-file-music2"></i> TRXD - Sometimes.mp3" & @CRLF & _
"<i class=" icon-info3 text-success" data-popup="tooltip" data-html="true" title="<b>Uploaded on:</b><br/> 2017-11-14 06:56:54<br> <b>Downloads:</b><br/> 7" data-placement="bottom"></i>" & @CRLF & _
"" & @CRLF & _
"</h6>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")