// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)<h6 class="panel-title">\s*<i class="icon-file-music2"><\/i>(.*?)<i class=" icon-info3 text-success" data-popup="tooltip" data-html="true" title="(.*?)" data-placement="bottom"><\/i>\s*<\/h6>"#).unwrap();
let string = "<div class=\"panel-heading\">
<h6 class=\"panel-title\"><i class=\"icon-file-music2\"></i> TRXD - Sometimes.mp3
<i class=\" icon-info3 text-success\" data-popup=\"tooltip\" data-html=\"true\" title=\"<b>Uploaded on:</b><br/> 2017-11-14 06:56:54<br> <b>Downloads:</b><br/> 7\" data-placement=\"bottom\"></i>
</h6>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}