import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h6 class=\"panel-title\">\\s*<i class=\"icon-file-music2\"><\\/i>(.*?)<i class=\" icon-info3 text-success\" data-popup=\"tooltip\" data-html=\"true\" title=\"(.*?)\" data-placement=\"bottom\"><\\/i>\\s*<\\/h6>";
final String string = "<div class=\"panel-heading\">\n"
+ " <h6 class=\"panel-title\"><i class=\"icon-file-music2\"></i> TRXD - Sometimes.mp3\n"
+ "<i class=\" icon-info3 text-success\" data-popup=\"tooltip\" data-html=\"true\" title=\"<b>Uploaded on:</b><br/> 2017-11-14 06:56:54<br> <b>Downloads:</b><br/> 7\" data-placement=\"bottom\"></i>\n\n"
+ "</h6>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}