import re
regex = re.compile(r"<h6 class=\"panel-title\">\s*<i class=\"icon-file-music2\"><\/i>(.*?)<i class=\" icon-info3 text-success\" data-popup=\"tooltip\" data-html=\"true\" title=\"(.*?)\" data-placement=\"bottom\"><\/i>\s*<\/h6>", flags=re.DOTALL)
test_str = ("<div class=\"panel-heading\">\n"
" <h6 class=\"panel-title\"><i class=\"icon-file-music2\"></i> TRXD - Sometimes.mp3\n"
"<i class=\" icon-info3 text-success\" data-popup=\"tooltip\" data-html=\"true\" title=\"<b>Uploaded on:</b><br/> 2017-11-14 06:56:54<br> <b>Downloads:</b><br/> 7\" data-placement=\"bottom\"></i>\n\n"
"</h6>\n"
" </div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")