const regex = /<h6 class="panel-title">\s*<i class="icon-file-music2"><\/i>(.*?)<i class=" icon-info3 text-success" data-popup="tooltip" data-html="true" title="(.*?)" data-placement="bottom"><\/i>\s*<\/h6>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<h6 class="panel-title">\\s*<i class="icon-file-music2"><\\\/i>(.*?)<i class=" icon-info3 text-success" data-popup="tooltip" data-html="true" title="(.*?)" data-placement="bottom"><\\\/i>\\s*<\\\/h6>', 'gs')
const str = `<div class="panel-heading">
<h6 class="panel-title"><i class="icon-file-music2"></i> TRXD - Sometimes.mp3
<i class=" icon-info3 text-success" data-popup="tooltip" data-html="true" title="<b>Uploaded on:</b><br/> 2017-11-14 06:56:54<br> <b>Downloads:</b><br/> 7" data-placement="bottom"></i>
</h6>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}