$re = '/.*\//';
$str = 'https://example.com.ua/part1/part2/part3/product-123.html';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;