# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)\\/\?(.*)/$1.html\/$2/gm;t' <<< "https://www.something.com/cat/man/clothing/?colourfilter=blue_red"