import re
regex = re.compile(r"(.*)\/\?(.*)", flags=re.MULTILINE)
test_str = "https://www.something.com/cat/man/clothing/?colourfilter=blue_red"
subst = "$1.html/$2"
result = regex.sub(subst, test_str)
if result:
print(result)