$re = '/(.*)\/\?(.*)/m';
$str = 'https://www.something.com/cat/man/clothing/?colourfilter=blue_red';
$subst = "$1.html/$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;