import Foundation
let pattern = #"(.*)\/\?(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://www.something.com/cat/man/clothing/?colourfilter=blue_red"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.html/$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)