use strict;
my $str = 'https://www.something.com/cat/man/clothing/?colourfilter=blue_red';
my $regex = qr/(.*)\/\?(.*)/mp;
my $subst = '$1.html/$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";