re = /(.*)\/\?(.*)/m
str = 'https://www.something.com/cat/man/clothing/?colourfilter=blue_red'
subst = '$1.html/$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result