// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)\/\?(.*)").unwrap();
let string = "https://www.something.com/cat/man/clothing/?colourfilter=blue_red";
let substitution = "$1.html/$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}