using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\s]+ ).*( .*)";
string substitution = @"$1router1$2";
string input = @"tunnel4 connection to router 1 status
gig1/0/1 blah status
g2/0/1 foo bandwidth";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}