import Foundation
let pattern = #"^([^\s]+ ).*( .*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
tunnel4 connection to router 1 status
gig1/0/1 blah status
g2/0/1 foo bandwidth
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1router1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)