re = /^([^\s]+ ).*( .*)/m
str = 'tunnel4 connection to router 1 status
gig1/0/1 blah status
g2/0/1 foo bandwidth'
subst = '$1router1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result