use strict;
my $str = 'tunnel4 connection to router 1 status
gig1/0/1 blah status
g2/0/1 foo bandwidth';
my $regex = qr/^([^\s]+ ).*( .*)/mp;
my $subst = '$1router1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";