import re
regex = re.compile(r"^([^\s]+ ).*( .*)", flags=re.MULTILINE)
test_str = ("tunnel4 connection to router 1 status\n"
"gig1/0/1 blah status\n"
"g2/0/1 foo bandwidth")
subst = "$1router1$2"
result = regex.sub(subst, test_str)
if result:
print(result)