import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\s]+ ).*( .*)";
final String string = "tunnel4 connection to router 1 status\n"
+ "gig1/0/1 blah status\n"
+ "g2/0/1 foo bandwidth";
final String subst = "$1router1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}