# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/href="\\//href="\\/more\\//gm;t' <<< "<html>
<head>
<title>Hello</title>
</head>
<body>
<p>this is a simple text in html file</p>
<a href=\"https://google.com\">Google</a>
<a href=\"/frontend/login/\">Login</a>
<a href=\"/something/work/\">Something</a>
</body>
</html>"