re = /href="\//m
str = '<html>
<head>
<title>Hello</title>
</head>
<body>
<p>this is a simple text in html file</p>
<a href="https://google.com">Google</a>
<a href="/frontend/login/">Login</a>
<a href="/something/work/">Something</a>
</body>
</html>'
subst = 'href="\\/more\\/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result