use strict;
my $str = '<html>
<head>
<title>Hello</title>
</head>
<body>
<p>this is a simple text in html file</p>
<a href="https://google.com">Google</a>
<a href="/frontend/login/">Login</a>
<a href="/something/work/">Something</a>
</body>
</html>';
my $regex = qr/href="\//mp;
my $subst = 'href="\\/more\\/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";