// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)href="\/"#).unwrap();
let string = "<html>
<head>
<title>Hello</title>
</head>
<body>
<p>this is a simple text in html file</p>
<a href=\"https://google.com\">Google</a>
<a href=\"/frontend/login/\">Login</a>
<a href=\"/something/work/\">Something</a>
</body>
</html>";
let substitution = "href=\"\\/more\\/";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}