#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)href="\/"
Local $sString = "<html>" & @CRLF & _
" <head>" & @CRLF & _
" <title>Hello</title>" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" <p>this is a simple text in html file</p>" & @CRLF & _
" <a href="https://google.com">Google</a>" & @CRLF & _
" <a href="/frontend/login/">Login</a>" & @CRLF & _
" <a href="/something/work/">Something</a>" & @CRLF & _
" </body>" & @CRLF & _
" </html>"
Local $sSubst = "href="\/more\/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)