# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"href=\"\/"
test_str = ("<html>\n"
" <head>\n"
" <title>Hello</title>\n"
" </head>\n"
" <body>\n"
" <p>this is a simple text in html file</p>\n"
" <a href=\"https://google.com\">Google</a>\n"
" <a href=\"/frontend/login/\">Login</a>\n"
" <a href=\"/something/work/\">Something</a>\n"
" </body>\n"
" </html>")
subst = "href=\"\\/more\\/"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.