#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\{(\d)}(\()"
Local $sString = "td{2}(i,j)," & @CRLF & _
"td{3}(i,j)," & @CRLF & _
"td{4}(i,j),"
Local $sSubst = "$2$1,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)