package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{(\d)}(\()`)
var str = `td{2}(i,j),
td{3}(i,j),
td{4}(i,j),`
var substitution = "$2$1,"
fmt.Println(re.ReplaceAllString(str, substitution))
}