import re
regex = re.compile(r"\{(\d)}(\()", flags=re.MULTILINE)
test_str = ("td{2}(i,j),\n"
"td{3}(i,j),\n"
"td{4}(i,j),")
subst = "$2$1,"
result = regex.sub(subst, test_str)
if result:
print(result)