use strict;
my $str = 'td{2}(i,j),
td{3}(i,j),
td{4}(i,j),';
my $regex = qr/\{(\d)}(\()/mp;
my $subst = '$2$1,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";