// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\{(\d)}(\()").unwrap();
let string = "td{2}(i,j),
td{3}(i,j),
td{4}(i,j),";
let substitution = "$2$1,";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}