import Foundation
let pattern = #"\{(\d)}(\()"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
td{2}(i,j),
td{3}(i,j),
td{4}(i,j),
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2$1,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)