#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(class|struct|enum|extension)[\h\S]*{$\n(?!\s)"
Local $sString = "// should trigger" & @CRLF & _
"public final class Aaaaaaa {" & @CRLF & _
"var cat: Bool" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"// should not trigger" & @CRLF & _
"class Aaa {" & @CRLF & _
"" & @CRLF & _
"var cat: Bool" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"// should not trigger" & @CRLF & _
"func bbb {" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"// should trigger" & @CRLF & _
"struct Ccc {" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"// should not trigger" & @CRLF & _
"struct Ccc {" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"// should trigger" & @CRLF & _
"enum Ddd {" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"// should not trigger" & @CRLF & _
"enum Ddd {" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"// should trigger" & @CRLF & _
"extension Eee {" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"// should not trigger" & @CRLF & _
"extension Eee {" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")