use strict;
my $str = '// should trigger
public final class Aaaaaaa {
var cat: Bool
}
// should not trigger
class Aaa {
var cat: Bool
}
// should not trigger
func bbb {
}
// should trigger
struct Ccc {
}
// should not trigger
struct Ccc {
}
// should trigger
enum Ddd {
}
// should not trigger
enum Ddd {
}
// should trigger
extension Eee {
}
// should not trigger
extension Eee {
}
';
my $regex = qr/(class|struct|enum|extension)[\h\S]*{$\n(?!\s)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}