using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(class|struct|enum|extension)[\h\S]*{$\n(?!\s)";
string input = @"// should trigger
public final class Aaaaaaa {
var cat: Bool
}
// should not trigger
class Aaa {
var cat: Bool
}
// should not trigger
func bbb {
}
// should trigger
struct Ccc {
}
// should not trigger
struct Ccc {
}
// should trigger
enum Ddd {
}
// should not trigger
enum Ddd {
}
// should trigger
extension Eee {
}
// should not trigger
extension Eee {
}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}