$re = '/(class|struct|enum|extension)[\h\S]*{$\n(?!\s)/m';
$str = '// should trigger
public final class Aaaaaaa {
var cat: Bool
}
// should not trigger
class Aaa {
var cat: Bool
}
// should not trigger
func bbb {
}
// should trigger
struct Ccc {
}
// should not trigger
struct Ccc {
}
// should trigger
enum Ddd {
}
// should not trigger
enum Ddd {
}
// should trigger
extension Eee {
}
// should not trigger
extension Eee {
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);