const regex = /(class|struct|enum|extension)[\h\S]*{$\n(?!\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(class|struct|enum|extension)[\\h\\S]*{$\\n(?!\\s)', 'gm')
const str = `// should trigger
public final class Aaaaaaa {
var cat: Bool
}
// should not trigger
class Aaa {
var cat: Bool
}
// should not trigger
func bbb {
}
// should trigger
struct Ccc {
}
// should not trigger
struct Ccc {
}
// should trigger
enum Ddd {
}
// should not trigger
enum Ddd {
}
// should trigger
extension Eee {
}
// should not trigger
extension Eee {
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}