# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(class|struct|enum|extension)[\h\S]*{$\n(?!\s)"
test_str = ("// should trigger\n"
"public final class Aaaaaaa {\n"
"var cat: Bool\n"
"}\n\n"
"// should not trigger\n"
"class Aaa {\n\n"
"var cat: Bool\n"
"}\n\n"
"// should not trigger\n"
"func bbb {\n"
"}\n\n"
"// should trigger\n"
"struct Ccc {\n"
"}\n\n"
"// should not trigger\n"
"struct Ccc {\n\n"
"}\n\n"
"// should trigger\n"
"enum Ddd {\n"
"}\n\n"
"// should not trigger\n"
"enum Ddd {\n\n"
"}\n\n"
"// should trigger\n"
"extension Eee {\n"
"}\n\n"
"// should not trigger\n"
"extension Eee {\n\n"
"}\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.